Issue:
On a client computer that is running Windows Vista or a later version of Windows, when you try to create an EveryonePrint Driver Print printer, you may receive an error message that resembles the following:
"Windows cannot connect to the printer. Check the printer name and try again. If this is a network printer, make sure that the printer is turned on, and that the printer address is correct."
This article exposes some of the issues that might prevent IPP or IPPS to work on Windows
Cause 1:
This error usually occurs when Windows feature 'Internet Printing Client' is not enabled on the client computer.
Please refer to these pages for information how to setup 'Internet Printing Client'
https://support.microsoft.com/en-us/kb/969708
http://superuser.com/questions/300986/ipp-printing-from-windows-7-ultimate
Cause 2:
If you have correctly enabled Internet Printing Client and still get the error, check that the device description in EveyonePrint Admin -> Devices doesn't contain the "&" sign; this will cause an error in the printer addition process.
As a quick fix, simply remove this "&" sign or replace for example with "+" : Printer B&W => Printer B+W
Cause 3:
If you're using secure IPP (over HTTPS) you may face some issue when using a self-signed SSL Certificate; check this MS KB article for detailed information: https://support.microsoft.com/en-us/help/2021626/when-attempting-to-add-an-ipp-printer-over-https-you-receive-an-error
Cause 4:
IPPS connection is not possible from ex Windows 7, but it's OK with Mac/Linux:
Windows 7 (and older Vista/XP) uses TLS V1.0 to make the SSL connection. Windows 8/10 and Mac/LINUX use newer TLS V1.2
On some occasion TLS V1.0 has been disabled in active network equipment, like proxy server, for security reasons; enabling TLS V1.0 again may solve the IPPS connection for older Windows OS.
Troubleshooting:
Ultimately, to verify that there is no connectivity or network issue preventing the IPP connection from the Workstation to the EveryonePrint server, you can test the following:
- Verify in EveryonePrint Admin -> General settings that Debug is enabled
- Select the Driver Print device URL like: http://srv-eop:631/ipp/r/34b09489102935/173BBF0E
- Open this URL in a Web browser -> you should get a blank page
- Check <eop-install-dir>\logs\eopwebservice.log file for these 3 lines
INFO | jvm 1 | 2016/05/26 15:14:13 | 2016-05-26 15:14:13,445 [13515521@qtp-2196493-6] DEBUG servlet.IppHanvdlerServlet service - Servletpath: /r/34b09489102935/173BBF0E
INFO | jvm 1 | 2016/05/26 15:14:13 | 2016-05-26 15:14:13,445 [13515521@qtp-2196493-6] DEBUG servlet.IppHandlerServlet service - RequestURI: /ipp/r/34b09489102935/173BBF0E
INFO | jvm 1 | 2016/05/26 15:14:13 | 2016-05-26 15:14:13,445 [13515521@qtp-2196493-6] DEBUG servlet.IppHandlerServlet service - Query: null
If you see these 3 lines in the log file, you have verified that there is not communication problem from the Workstation to the EveryonePrint IPP server.
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